Installing a Server OS in Intel Media Series Motherboards

Intel Motherboard.png

Having seen Missing Remote’s reviews of the Intel Media Series motherboards it should be clear that they provide a solid foundation for a home theater PC (HTPC) build, but because they also include Intel NICs (network interface controller) there is a strong case to use one for your next server build as well.  Unfortunately, Intel does not support server operating systems (OS) like Windows 2008 R2 (W2K8R2), which provides the foundation for Windows Home Server 2011 (WHS), so the installation process is more involved than it should be.  I didn’t have a USB key install of WHS handy so for this walk through I used W2K8R2; everything should be the same except that for WHS you can skip a step.  Let’s get started.

Getting the server OS actually installed was no different than Windows 7 (i.e. simple and uneventful) so we’ll assume everyone has that step covered.  After logging in I took a screen shot of Device Manager to show the devices that were undetected.  Not all of the drivers listed below are required to make it work, but we will install them anyway for completeness.


Like a Windows 7 install the first step to install the chipset drivers, which will clear up most of the undetected devices.  Everything worked without a hitch, so just click through and reboot.


I generally install the storage drivers next, but because the RST (Rapid Storage Technology) application requires .NET, which is not installed by default on W2K8R2, I decided to get the NIC working first.


Ironically, the major selling points of the boards turned out to be an issue – fear not, there is a workaround.


Unlike some of Intel’s other driver packages, PROSet does not extract the contents to a convenient, user accessible location so we will need to handle that manually.  Open a command prompt and enter the path to dump out the contents of the installer plus “/e /f c:\drivers”.  With the drivers available we will just walk through the “Have Disk” manual driver selection process. 


Select the “Ethernet Controller” device from Device Manager and then click “Update Driver”.


Select “Browse my computer for driver software”.


For some reason the drivers will not get chosen automatically, even when pointed at the correct folder; everything needs to be done manually so click on “Let me pick…”. 


Then click “Next”.


Windows doesn’t include the correct drivers so we need to choose “Have Disk”.


Then “Browse” to the location where the NIC drivers were extracted and click OK.


All of the 2011 Media Series boards we’ve looked at, including the DH67CF, have an 82579 Gigabit NIC so select that from the list and click “Next”.


Select “Yes” to install the driver.


And finally “Close” to complete the installation.


If you just want to get the NIC working, you’re done, but there are some features like Jumbo Frames and VLAN support that will not be configurable without the custom driver properties pages installed via the official driver.


So go ahead and click through the PROSet installer; it will work this time because we’ve already installed the driver.


The next step is to install the USB3 drivers – no problems here.


.NET 3.5 is required for RST and MEI to install properly, and the easiest way to do that is via the built in feature.  Note that WHS users shouldn’t have to do this step as WHS includes .NET out of the box.


Then click through the RST install and reboot.


As well as MEI.


The last step is to install the graphics driver.  Unlike any other driver, this one is totally optional (especially if running headless) because W2K8R2 includes a driver that will work fine.  The installer won’t go on cleanly because of a dependency on components not included by default with W2K8R2 (activating the “Desktop Experience” should sort this though, the dll that fails to register is a Media Foundation Transform), but both the video and audio (HDMI) drivers will so the important bits are covered after a reboot.


Will all the drivers installed we’re finally done.  For those using WHS there isn’t much left to do except install some addins and setup users and shares.  Those going with W2K8R2 this is just the first step to setting up Hpyer-V, IIS, file & printer sharing, a DNS or DHCP server.

Related Articles

  • Awesome writeup, thanks Andy.

    Awesome writeup, thanks Andy. At some point if I ever move from WHS to WHS 2011 I will probably build another server. My current server is an AMD build in which I added a separate Intel NIC, so just going with an Intel build next go round probably makes the most sense. I will definitely bookmark this for later use Smile

  • I’m glad you wrote this up,

    I’m glad you wrote this up, Andrew, because I would have had to do all this legwork myself since I am planning a WHS 2011 build on an Intel board.

  • My server is running an Intel

    My server is running an Intel G965HW and it’s great! Much better then the board I was using before.

  • Just stumbled across this

    Just stumbled across this while having the exact problem of installing drivers on my H67 board using WHS11.  My driver disk that came with the motherboard has the intel chipset driver installer you’ve illustrated above, but the WHS11 software keeps interrupting and trying to connect to my network before I can get the installation disk booted–it opens a screen that blots out everything else with a progress bar with a blue dash moving across the screen with a “Back” button that does not work, and after about 5 minutes an error message pops up that says it cannot find a network connection, which I assume really means that the network adapter is not working because no drivers (my device screen looks just like you’ve illustrated above.  This is probably a stupid question, but could you tell me how to stop the installation long enough to get the drivers installed as your guide shows?  I’ve tried several things, but nothing works.

    • I’ll have to check it out. 

      I’ll have to check it out.  Should have time in the next few days.

    • Had a chance to run through

      Had a chance to run through the install last night and the experience was pretty much the same (have disk, browse and choose the NIC driver, etc) from the Device Manager dialog that shows when selecting “Install Network Drivers” during the install process.  I did have the drivers on a USB key, so that made it more convenient.

  • I remember it being a little

    I remember it being a little tricky to pick the driver for the NIC because you have to specify the exact driver.  I had to go to to find the specs for the board, find which Intel NIC chipset it was, then select from the list.  Sounds easy, I know, but there was something screwy about it that I just don’t remember.  Maybe I had to look inside the darn INF files to see what exactly they referred to.  Not sure, but it wasn’t the same as the screen shots above for 2008 R2.

  • Thanks for responding Andrew

    Thanks for responding Andrew and RMan.  I’m trying to sort through why I’m having trouble when so many others aren’t, and I’m such a newb I don’t trust myself.  First of all I’m assuming that the only operating system on the computer is WHS 2011.  During my install, I never got a dialogue “Install Network Drivers”.  As I noted above, the only thing that I got after the initial desktop view during installation, after about 15-20 seconds it defaulted to the progress page that I assume appears because it is trying  to connect to the network, and then the error message that it can’t connect. 

    The only thing that overrides that page is if I quickly click on the “Server Manager” button before that page starts.  Doing that and going to the Device Manager within Server Manager, I have managed to install all the drivers but “ethernet controller”.  I’ve located the correct controller on the Intel website, but it downloads as an “exe” file.  My flash drive that I downloaded the driver to shows up ok in the device manager driver update window, but it won’t “browse” to the driver itself, I guess because it has to “run” and I don’t see any way of running a program from within the device manager or anywhere else within Server Manager.  And because my installation is not complete, I don’t see how I can run it any other way.

    So, have I got a bad installer, or a motherboard that’s so wedded to Windows that it won’t cooperate, or is the motherboard so advanced that it doesn’t need the drivers to connect initially, and the problem is something else entirely, like the fact that my router is locked down and needs an encryption key for the server to log on (if that’s the case it doesn’t give may any opportunity to enter the key)? On another forum someone having similar driver issues gave up on his motherboard.  At any rate I’m stumped.  If anyone has any further suggestions, I would greatly appreciate your help. 

  • Thanks for your replies.  The

    Thanks for your replies.  The NIC for the motherboard I have downloads from Intel as an installation program (exe file), which I can’t run in the device manager, which only recognizes ini files.  Any suggestions on what ini driver to try to get this going?  The motherboard I have is an Intel based H67 1055 for i3-i7 cpus.

    • Andrew Van Til

      Use the method documented in

      Use the method documented in the guide to extract the NIC driver exe w/o installing it.  Then follow the method documented in the guide to browse to it and selected the model used by your board.

  • Thanks Andrew.  Sorry I’m

    Thanks Andrew.  Sorry I’m such a newb.  What I have been missing is the extraction of the drivers from the installation disk.  Since I have never been able to complete the installation of WHS 2011, I can’t get to a command prompt in the server, so I will try to do that on my laptop and copy the drivers to a flash drive.  I’m over my head here, though.  So I may need to get back to you.

    • Andrew Van Til

      Once they are extracted to

      Once they are extracted to the USB drive it should be straightforward.  Just make sure they are the x64 ones 🙂

  • Kudos, Andrew.  Finally got

    Kudos, Andrew.  Finally got it done with your much appreciated help.  Was not as straightforward as your guide because my drivers were Intel based Realtek, which had exe files within exe files on the installation disk, but I found a guide on the internet using 7zip to crack the multiple exe files, which got me to the required drivers.  No need to respond to this, but I’m still puzzled why you were able to complete the WHS installation without establishing a network connection and I wasn’t.  Thanks again.

  • Thanks so much for writing

    Thanks so much for writing this guide up, Andrew. I found it quite helpful for WHS2011 installation. Here are a few pointers for anyone doing WHS2011 install:

    1. Load up all drivers onto USB stick

    2. During WHS install, an error will occur preventing you from going further due to lack of NIC driver. CTL-ALT-DEL, Start Task Manager and kill the setup routine.

    3. Run cmd.exe as admin

    4. Dump the NIC drivers exactly as Andrew has described

    5. Install all drivers as the guide shows. Since it is WHS, none of the errors in the guide will apply.

  • Hi,
    I am planning on


    I am planning on upgrading my WHS 1 platform to an Intel DH67BL/Celeron G620 combo.

    Many of the drivers you list above are not supporting neither WS2008R2 nor WS2003 (at least not if you search drivers using the model of your motherboard – e.g. the DH67BL: Although many of them (Chipset, NIC, RST) can be found on Intel’s page in versions where WS 2008R2/2003 support is listed, but I haven’t managed to do so for the ME, USB3 and HD Graphics drivers. They only seem to support Win7, Vista and WinXP. Are these the drivers you used under WS 2008 R2 and do you know if they will support WHS 1 (WS 2003)?



    • AFAIK, there is no

      AFAIK, there is no combination of drivers that are “supported” on Media Series motherboards when running a server OS.  Sometimes “not supported” means doesn’t work, but in this case it just means that Intel won’t help you out if there’s a problem and there are some nuances in getting some of the drivers installed.

  • The Intel executable files

    The Intel executable files for the LAN drivers and the Graphics drivers are actually self extracting ZIP files.  If you want, you can open the executable driver files with WinZip or Izarc and extract the files that you need without following the procedure that Andrew so kindly provided.  Andrew provided the seed, but I am too lazy to follow his excellent instructions.

  • Hey Guys!
    I have an Intel®

    Hey Guys!

    I have an Intel® Desktop Board DH67CL and managed to get some devices in. Im still having problem with:

    SM Bus controller and mass storage controller. Are they important?

    The reason I ask is that Im having serious problems copying files between disks or in the network. 1 file goes OK, but then WHS 2011 hangs…



  • EDIT:  Please don’t post the

    EDIT:  Please don’t post the same thing in two places.  Most people are more than capable of reading your post and question in just a single location.  Duplicate posts just annoy us mods.

    Thanks…  Skirge01



  • Hello,
    many thanks for your


    many thanks for your threads, it was the only helpfull what i found on the web, about W2008r2 and intel drivers. i have a new intel h77 kc board with a ivy bridge cpu, and the os ist win2008r2. with your help i have installed my nic but i fail in installing the intel hd driver for windows 2008r2. If i try to start the setup i receive a error message, its not a supported os… if i extract the driver zip file and try to install manually, like the nic, it doesent work.

    Have anyone a idear? Thanks a lot for your help, and sorry for my poor english, im from munich, bavari.

    thanks and regards


    • The video drivers aren’t that

      The video drivers aren’t that important for most servers since there headless, so I wouldn’t worry about it too much. I’ll take a look when I get a chance though, you might be able to modify the installer packaged to removed that safeguard.

  • Has anybody gotten the rapid

    Has anybody gotten the rapid storage raid to work w/2008? I loaded to 2TB drives in the box and setup raid 1 via bios but can’t get 2008 install to see it…

  • An update to this

    An update to this procedure… Today, I decided to update my drivers and I noticed that WHS2011 was detecting the NIC as 82579LM vs. Windows 7 machines which detect the 82579V. I found you can fix this with a simple tweak to the .inf.


    1. Extract the drivers files. (I use 7zip for this)
    2. In notepad or your favorite text editor, open (exctracted driver folder)PRO1000Winx64NDIS62e1c62x64.inf
    3. Delete all the lines under the [ControlFlags] section.
    4. Copy the five lines beginning in %E1503NC under the [Intel.NTamd64.6.1.1] section.
    5. Paste those five lines just below the line beginning with %E1502NC in the [Intel.NTamd64.6.1] section.
    6. Save the file.
    7. Run the install in (exctracted driver folder)APPSPROSETDXWinx64PROSETDX.msi or if you just want the driver only, you can run (exctracted driver folder)APPSSETUPSETUPBDWinx64SetupBD.exe

    I have attached the modified driver file from the v17.2 driver for reference.

    • Do you think it makes a

      Do you think it makes a difference? I’ve been running mine as a LM the whole time 🙂

      • I’m not really sure. I was

        I’m not really sure. I was doing the same as well. I only just noticed the difference since I was upgrading all of my systems at the same time and just happened to notice that.

  • Has anybody tried this with

    Has anybody tried this with Windows Server 2012 Essentials yet?