Windows Media Center Update Notification

Home Forums Windows Media Center Windows Media Center Update Notification

Viewing 3 posts - 16 through 18 (of 18 total)
  • Author
  • #32538

      I got this to work today on the HP, instead of ending process, I went with End Process Tree, then right clicked the ehtray.exe and run as administrator. Then I went to the guide and right clicked on a channel and chose Update Guide Now. The pop up worked. This is the first time I’ve been able to do this on the HP Pavillion (I just installed the new Java7-5 64 bit and 32 bit before I did this, but don’t see how that should impact the operation.)




        I’ve had mixed luck with the ehtray.exe end process and then running it from the ehome directory as administrator. BUT what I noticed today is that there are multiple instances of ehtray.exe running. It looks as if there is a copy for each extender which is logged on to the system. So as a test I ended process on the copy in task manager but there were three left in Resource Monitor. I logged out and back in and still found a couple of copies running. But I found that I could right click on the item in the CPU setting of resource monitor and choose end process. Then you have to wait for it to close. After they were closed I opened ehome and right clicked on ehtray.exe and chose run as administrator. After a few seconds it was added back to Task Manger and within a few more minutes I had a total of four copies running in Resource Monitor.

        I’ve found the best method is to wait for the automatic update to run the task so I won’t know now until tomorrow if I get an icon with a pop up or if it still is “silent.”


        Update 8/18 7AM, well the pop up is working (currently shows Client Mant. Complete) but turning off all the other “ehtray.exe” running and then starting one on the Dell as administrator and letting the machine restart the rest seems to have worked.


        Still looking for a way to mark this service to start properly at boot up or start of Media Center to work properly all the time.

        Anyone with more advice, please comment.




          More complications. I was still “hit or miss” on my Dell machine and when I did a search on the system drive I found three copies of ehtray.exe. Two of them were in the winsxs/ folder with a very long folder name. But one of them was dated 2009 and the other dated 2010 which matched the one in ehome.

          Throwing caution to the wind, I went through the dance to take ownership of the folder with the 2009 ehtray.exe and copied it to a backup folder and then deleted it from the winsxs/ folder.

          Waiting results from the lab now. (After that operation I went through the stop process and then run as administrator from the ehome directory.) I’m just wondering if “sometimes” the 2009 copy got accessed or the fact there were two in the winsxs folder caused trouble or?

          Time will tell…….

          After stopping the ehtray.exe service and restarting as administrator and waiting for the next automatic update the notification pop-up appeared. It remains to be seen if this will work after a reboot.

        Viewing 3 posts - 16 through 18 (of 18 total)
        • You must be logged in to reply to this topic.