HTPC & new AVR = sad panda

Home Forums Home Theater Computers HTPC & new AVR = sad panda

This topic contains 18 replies, has 5 voices, and was last updated by  Night Rider 3 years, 7 months ago.

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #26905

    I have a Win7 MCE HTPC (Intel SandyBridge Video) that I’ve run for years with HDMI directly to the TV (Panasonic plasma) and spdif to my old AVR. I just bought a new Denon AVR (2100) and am re-learning the (un)wonderful world of HTPC+AVR.

     

    I’m seeing some HDCP issues when trying to watch TV after switching inputs on the AVR. Requires a restart of the HTPC. Also switching inputs on the AVR causes MCE to snap back to the 640×480 or whatever because of the Windows monitor disconnect issue.

     

    So after reading I decided the HDMI pin 19 trick might be the fix I need. The problem I’m running into is after taping off pin 19 I don’t get any video signal. If I connect the HDMI cable to the AVR or directly to the TV I can see the PC boot up, BIOS screen but right after the Windows boot logo switches to the logon/desktop the signal disappears. If I remove the tape it all works again. I’ve been searching the web all night but haven’t seen that behavior described when messing with pin 19. I’ve tried redoing the tape a half dozen times in case I was covering up some additional pins or something. Anyone have any thoughts? Thanks in advance.

    #33538

    babgvant

    The HDCP issue can be resolved by using a 12’+ HDMI cable, and you can use StandbyHelper to help with the resolution problem.

    Best fix requires some $ though. Put a HDMI detective b/w the PC and the AVR.

    #33539

    inane69

    Using a very long HDMI cable can help HDCP handshaking issues?

    #33540

    babgvant

    [quote=inane69]

    Using a very long HDMI cable can help HDCP handshaking issues?

    [/quote]

    Yes, I know it sounds crazy. I found this issue with Clarkdale and Denon AVR, still exists on SNB.

    Have a look: http://www.missingremote.com/review/intel-sandy-bridge-core-i5-2500k-and-dh67bl-motherboard

    Scroll down to the HDCP section.

    #33541

    inane69

    I appreiate the tip but doesn’t seem to work for me.  With my short 3′ cable or a ~12′ one I happened to have, they both show that HDCP is supported (see attachments).  I’m wondering if my problem is a HDCP one.  The error I get in MCE only seems to happen when trying to watch TV which is why I thought it was related to HDCP.  I’ve attached that error as well.

    If I simply turn the TV off then back on (leaving the AVR on) then it usually will start working.

    #33542

    Night Rider

    I only see HDMI screens and not HDCP.

    I receive a similar error via Display Port from my GTX Titan Black and my Display Port only ROG Swift PG278Q ‑ 27″ LED QHD Monitor.

    Check under you GPU control panel
    For Nvidia it will be listed under
    Display/view HDCP status
    I don’t own an AMD card so can not advise on that.
    See if your graphics card and display are showing as HDCP-capable.


    #33543

    babgvant

    Yeah, that’s a different problem. Let’s narrow it down. What all have you tried?

    Restart WMC?

    Restart PC?

    Restart TV: check

    Restart AVR?

    Unplug/replug HDMI?

    Redect display from “Display setting” control panel item?

    #33544

    inane69

    [quote]

    Check under you GPU control panel
    For Nvidia it will be listed under
    Display/view HDCP status
    I don’t own an AMD card so can not advise on that.
    See if your graphics card and display are showing as HDCP-capable.

    [/quote]

    I know what you mean with Nvidia but Intel graphics on this system don’t have any HDCP information.  Look at my 3rd pic above thou.  The AVR properties in Windows think HDCP is good.

    #33545

    inane69

    [quote=babgvant]

    Yeah, that’s a different problem. Let’s narrow it down. What all have you tried?

    Restart WMC?

    Restart PC?

    Restart TV: check

    Restart AVR?

    Unplug/replug HDMI?

    Redect display from “Display setting” control panel item?

    [/quote]


    After more testing I found that this issue is not HDCP because when it is in a non-working state no videos of any kind will play.  Including Recorded or Live TV and mkv’s, mp4’s, etc.

      

    Here is the testing that I did:

      

    I have my Harmony power on sequence:

     

    AVR

    phantom device

    phantom device

    TV

    (HTPC is always on)

     

     It seems like most of the time from a powered off state that works.  I haven’t really noticed yet if the intial power on result is different between long periods or short.

     

     So from a bad state I tried this:

     Unplugged HDMI between AVR and TV – came back to find MCE crashed, started MCE back up but no joy.

     Unplugged HDMI between AVR and HTPC – came back to MCE in 4:3 but if I go straight to live TV it worked!  So then I try to close MCE and open again to get it back to full resolution and TV stops working.

     Restarted HTPC – Live TV still errors out.

     Tried unplugging HDMI between AVR and TV again – This time came back to MCE in full resolution and TV works!

     One more test, simply closed out of MCE then reopened it – TV no longer works!

     Power cycled the TV – Live TV works again!

      

    To me it seems MCE needs to sync with the TV somehow at some level above the OS.  And since it affects all types of video I don’t see how it’s HDCP causing that.

     Thoughts? (and thanks!)

    #33546

    babgvant

    Yeah, that’s a tough one. Does the outcome change at all if you close WMC before powering off the AVR+TV? How about if you turn on the TV before the AVR? It’s possible that there’s something wonky in the timing.

    If it doesn’t, I think it’s probably an problem that you’ll have to use an HDMI detective for.

    #33547

    ccarlin

    I have similar issues whenever I change inputs from my HTPC.  The only workaround that I have found that works consistantly is to leave it on a paused video.  As long as I do that I can switch the inputs without any issues.  

    #33548

    babgvant

    Some AVR sever the HDMI connection when  switching inputs, which makes the PC renegotiate the connection – which doesn’t always go well. The best approach is to use a HDMI detective, but it’s not always suitable, since it’s an extra hardware cost.

    #33549

    inane69

    The more I use this setup the more it appears to be an anoyance than a show stopper.  It’s pretty easy for myself to diagnose.  I guess the only concern is if another family member tries to use the room which is kinda rare since my kids are still young and mostly use a TV elsewhere.

    I appreiate everyones sugestions.  I just wanted to make sure there wasn’t something I hadn’t thought of.  I’ve used HTPC’s for over 10 years now, just have managed to (mostly) avoid running them thru AVRs.  I’ve been considering moving MCE to run as a VM and just use my Xbox 360’s as extenders since they act more like appliances.  I don’t expect they would have as many issues with the AVR.

    #33550

    Night Rider

    I have been following this thread to see if a solid resolution could be found to your issue.
     

    #33551

    oliverredfox

    Peronally I picked up a HDMI Detective years ago to deal with this.  But with how cheap a used Xbox 360 is, I’d likely run headless on the HTPC and use an extender these days.

    [quote=inane69]

    So after reading I decided the HDMI pin 19 trick might be the fix I need. The problem I’m running into is after taping off pin 19 I don’t get any video signal. If I connect the HDMI cable to the AVR or directly to the TV I can see the PC boot up, BIOS screen but right after the Windows boot logo switches to the logon/desktop the signal disappears. If I remove the tape it all works again. I’ve been searching the web all night but haven’t seen that behavior described when messing with pin 19. I’ve tried redoing the tape a half dozen times in case I was covering up some additional pins or something. Anyone have any thoughts? Thanks in advance.

    [/quote]

    Since pin 19 effects monitor detection, it’s likely Windows isn’t seeing it right and doing a weird setup/resoltion causing it to not have a signal at the logon/desktop point.  Try putting something like Chrome Remote desktop on your system (and make sure you can connect right on boot with a phone, tablet, or other computer).  Then reboot with the pin 19 mod.  Once it’s booted, use the remote desktop to go into your settings and manually force the monitor correctly with the right resolution/refresh rate/etc.

Viewing 15 posts - 1 through 15 (of 19 total)

You must be logged in to reply to this topic.