A quick HDMI question.

Home Forums Home Theater Construction Help A quick HDMI question.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #26719

    I have always run my sound via optical TOSLink connectios (priamrily because my AVRs are old and don’t have HDMI inputs). 

    This weekend I purchased a new Yamaha AVR with HDMI switching, removed all the old cables and used a 6′ HDMI cable to connect the HTPC to the AVR, a 12′ for the BR player to AVR and another 12′ from the AVR to my Sharp LED-LCD.

    While watching Live TV I noticed that after 5~15 min of viewing the sound would start dropping out.  In the telecom bussiness we call it bouncing, it will drop out for about 1 sec, then come back for 10-30 sec, drop out for 1 sec, etc…  when the sound drops out the surround indicator on the new AVR goes out, it seems like it is losing sync with the HDMI signal. 

    There are no problems with the video at all, it continues to play perfectly even when the sound is bouncing. 

    If I change channels or pause and resume live TV the bouncing stops for 5-15 min then starts again.. 

    The audio bouncing is only observed with Live TV, recorded TV, or MPG/MKV playback from my WHS2011 is perfect with no audio bouncing. 

    My Ceton tuners are networked from the same WHS2011 and no audio bouncing ever occured when my sound was run via optical.

    In some previous posts I recall reading that longer HDMI cable are prefered, I don’t recall why. 

    I did rearrange the cables just before bed, not long enough to verify a fix, but they are now arranged with 12′ from the HTPC & BR to the AVR and 6′ from the AVR to the TV.

    Should I get another 12′ for the AVR to TV run?  Any other thoughts?

    Update;  I am using a Gigabyte MB with an AMD A4 APU and the latest CCC software.

    #32756
    Aaron Ledger

    The difference in cable length for HDMI that you are refrencing is typically to account for HDCP negotiation which doesn’t sound like the issue you are having. Does the issue occur with bitstreamed audio (e.g. sending Dolby Digital audio direct to AVR for decoding) as well as with PCM audio (this is audio that’s already been decoded by the PC)? Can you plug the HDMI cable direct to your display and still get the issue?

    #32757
    babgvant

    Do you have any 3rd party CODECs installed? If so, it’s possible that they are joining the graph and causing problems. Also, make sure that you have the correct ATI HDMI audio driver installed. Their drivers are Reltek based so I’ve seen issues where the wrong one gets selected.

    #32758
    phoneguyinpgh

    Aaron,

    I spent all evening on this one.  I reinstalled the audio drivers, no joy. I tried the AVR and TV set up with Audio Return Channel enabled and disabled, no joy x2.

    I sent the HTPCs HDMI cable straight into the TV using the TVs speakers and HDMI audio and no bouncing audio.  I moved the HDMI cable back to the AVR and the audio is bouncing again.

    The only audio I decode on the HTPC is music, mp3’s.  All other material, video, has it’s audio bit-streamed (either optical or HDMI) and decoded by the AVR.

    Only Live TV has bouncing audio.  No other video source on the HTPC has this issue.  I can play MPGs, MKVs, DVDs, BluRays and recorded TV both HD & SD with no bouncing audio.

    When the audio starts to bounce and I press the skip forward button (even though I never paused the Live Tv) the bouncing stops for 5~15 min and then starts bouncing again.  The duty cycle of the bouncing is also varying from 2~3 sec to 15 or so between bounces.

    I disabled all other audio devices both output and input, still no joy.

    I am thoroughly stumped on this one.  I’ve gone back to optical for the HTPC until I can figure this out.

    #32759
    Aaron Ledger

    Definitely an odd problem.

    1. Tune to a non-AC3 (Dolby Digital) audio program. These will have MPEG audio and WMC will decode to stereo PCM. Is the result the same? It may actually work properly because you may have not been bitstreaming to the TV as they often only accept PCM.

    2. It is possible that perhaps there is some strange HDCP event happening so you could go on trying different cables as well as trying the video out to TV and audio out to AVR using separate cables. I’m not sure the exact capabilities of the board you have so you may actually require a second test GPU to try the dual cable approach.

    3. Have a backup plan of getting a different vendor’s AVR or system if all else fails. Sometimes there are strange incompatabilities with HDCP if that is what the cause ends up being. 

    #32760
    phoneguyinpgh

    Andrew,

    1.  I am using Shark007 for MKV playback.  I uninstalled them and still have bouncing audio.

    2.  The drivers state that they are from Realtek so I am assuming they are correct.

    Aaron,

    1.  None of the OTA or Fios channels are using PCM audio.  I did try a 1 chan DD station and it bounced as well.

    2.  I think you may be right, there may be some HDMI<>HDMI Ooggidy-Booggidy going on that I don’t have the time, resources or technical wear-with-all to resolve.  I’m just not that good.

    3.  I am going to fall back to the optical link for the HTPC. 

    All my rips are in DD or DTS.  Since the optical link can send PCM, DD & DTS I’m not losing anthing I had before.  I just wanted to get rid of an extra cable and hopefully simplify some things.  I have never been able to get subtitles or 24fps video to work on my HTPC either, that’s the reason I have a networked BluRay player that I can put the original disc into and get subtitles, 24fps and now it appears DD-HD and DTS-HD sound as well if I so chose since the BR players’ HDMI connections is working fine.

    Thanks for the suggestions.  If anyone has a solution I’d love to hear it and I’ll give it a try.  Not urgently needed, just curious.  Thanks again.

    #32761
    babgvant

    [quote=phoneguyinpgh]

    1.  I am using Shark007 for MKV playback.  I uninstalled them and still have bouncing audio.

    [/quote]

    Might want to check to make sure that you don’t have ffdshow or LAV Audio installed. I have seen a similar issue with LAV Audio. It is not suitable for WTV playback with the SBE source, but often joins the graph anyway.

    FWIW, you don’t need to install Shark007 to get MKV working. You only need LAV, then make a few tweaks – I’ll try to make the time to document the process this week.

    [quote=phoneguyinpgh]

    2.  The drivers state that they are from Realtek so I am assuming they are correct.

    [/quote]

    I’m pretty sure it should be the “ATI HDMI” one, you should be able to swap them in Device Manager (reinstalling it probably won’t work).

    #32762
    phoneguyinpgh

    I am using LAV audio and video through the SHARK007 pack.  I have it set to bit stream audio for all formats with no other alterations set.  I use LAV for video decoding of H264 and VC1 encoded MKVs.  Should I disable MPG audio and video decoding in LAV video and audio?

    The device properties says that it is ATI HMDI audio and the drivers author is RealTek.  Is there a different driver I should be looking for to use with the ATI HMDI audio?  How do I tell which is which?

    #32763
    Aaron Ledger

    Perhaps you should try eliminating any 3rd party codecs altogether until you get the issue sorted out just to rid yourself of those easy targets first.

    #32764
    Aaron Ledger

    It is interesting that your audio driver is labeled ATI and made by Realtek. I suppose that is what the particular hardware takes. For my 6570, the latest Catalyst installs an AMD-branded HDMI audio driver with no references to Realtek.

    #32765
    phoneguyinpgh

    I uninstalled the codecs last night and still had bouncing audio.  Through trial and error I found that the LAV codecs are the most efficient and use the least CPU with smooth playback. 

    To my best knowledge the HDMI audio driver loaded with CCC.  I’m not sure how to browse my system to find a potential alternate driver, but when I remove the item from device manager Win always automatically rediscovers the current driver.

    One thing I did notice is that, when I disable the the HDMI audio device, the TV speakers still have sound.

    #32766
    Aaron Ledger

    To eliminate all traces of a driver, you can go to the cmd prompt and enter “set devmgr_show_nonpresent_devices=1”. Then open up devmgmt.msc (Device Manager) and click the option to show hidden devices. 

    #32767
    babgvant

    [quote=phoneguyinpgh]

    I uninstalled the codecs last night and still had bouncing audio.  Through trial and error I found that the LAV codecs are the most efficient and use the least CPU with smooth playback. 

    [/quote]

    I use LAV on my WMC, but it’s important to tame it since it will break WTV (SBE) playback (especially Live TV). Get a copy of GraphStudioNext (or GraphStudio) that matches your platform (x86/x64) and run it with administrative privileges. Browse for a filter and see if LAV Audio is installed, if it is lower the merit to a sane value (or maybe even do not use to troubleshoot) then reboot.

    [quote=phoneguyinpgh]

    To my best knowledge the HDMI audio driver loaded with CCC.  I’m not sure how to browse my system to find a potential alternate driver, but when I remove the item from device manager Win always automatically rediscovers the current driver.

    [/quote]

    I had the same issue with the Llano system reviewed earlier. You need to explicitly set the AMD HDMI Audio driver in Device Manager using the method below (sorry don’t have an AMD system handy).

    #32768
    phoneguyinpgh

    Andrew,

    Thanks… I will give this a try when I get home from work.

    Update:

     

    1st I restored a system backup from before I started all the messing around.

     

    I checked for an ATI authored driver and there aren’t any in the system.  All the compatable drivers are authored by RealTek.  I think it may be due to the fact that the HDMI port is on the MB and not a discrete graphics card. I do think that the driver is the issue and not LAV audio since live TV audio is not broken it just starts to bounce after 5 min. I’ll check around for an update. Thanks for the help.

     

     

     

     

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.