Ceton Tuner in ESXI Problem

Home Forums Home Theater Computers CableCARD Ceton Tuner in ESXI Problem

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #26676

    Hello,

    So I have a virtual windows machine with my ceton tuner working. I have my HTPC’s around the house all setup to connect.

    My problem is that I will get a weak signal error when I use more than one machine. I hit the stop button, then select the same channel and all seems to be ok…

    Is this a sign of poor networking? What I did was pass through my on board NIC to the windows VM and that is bridged with the ceton card…

    Just curious if anyone would know what is up. This didn’t happen when the card was in my main HTPC.

    Thanks

    #32581
    FantaXP7

    Guess I really stumped people here Laughing

    Take away the fact that the card is being using in a virtual machine. Has anyone else seen something similar to the poor signal that occurs with multiple machines accessing the Ceton?

    Thanks

    #32582
    Aaron Ledger

    It sounds like you’re looking in a good direction with the idea that there could be a networking issue. Have you checked any of your network interface statistics to see if there are any errors? Do you have flow control enabled on all of your PC NICs? What type of switch(es) are you using? Are you using FastEthernet, Gigabit or combination of both?

    Another thing to consider playing with is the NIC interrupt moderation settings. You could try disabling to see if it helps.

    #32583
    mikinho

    Sounds like packet loss or latency issues. What network card do you have?

    Can you go over your network topology and Hypervisor setup?  For instance, you really should never share a network card between the host and its virtuals. 

    #32585
    FantaXP7

    [quote=Aaron Ledger]

    It sounds like you’re looking in a good direction with the idea that there could be a networking issue. Have you checked any of your network interface statistics to see if there are any errors? Do you have flow control enabled on all of your PC NICs? What type of switch(es) are you using? Are you using FastEthernet, Gigabit or combination of both?

    Another thing to consider playing with is the NIC interrupt moderation settings. You could try disabling to see if it helps.

    [/quote]

     

    Thanks for the reply,

    I’ll have to look into some of these things as I am not too certain of all of them, but my switch is Gigabit, flow control is enabled on the main (I will check other HTPC’s).

     

    #32586
    FantaXP7

    [quote=mikinho]

    Sounds like packet loss or latency issues. What network card do you have?

    Can you go over your network topology and Hypervisor setup?  For instance, you really should never share a network card between the host and its virtuals. 

    [/quote]

    Thanks for the reply,

    I have passed through the onboard NIC which is a Realtek 8111E and that is bridged with the Ceton. I also have a Intel NIC which is being used with my only other VM which is FreeNAS. I was thinking it may be a good idea to throw in another Intel NIC and pass it through to the Win7 VM to replace the onboard Realtek.

    Not sure if these would play a role at all, but I have an i5 2400 as a cpu. Would hyperthreading be necessary at all?

    Also, the host is currently sharing a connection with the FreeNAS VM and I haven’t had problems. But I assume from what you  are saying they should have separate NICs? I could use the onboard for ESXI, pass through an intel NIC for FreeNAS and for Win7 if that is an ideal setup.

    Thanks for any input.

    #32587
    mikinho

    As a first step I would try assigning the Realtek to the host only and using the Intel w/ the virtual HTPC. I think you’ll see some improvement from that alone. Another Intel NIC (preferably w/ VMDq) would be the next step.

    Note: On ESXi VMDq is disabled by default but with the proper NIC can offer noticeable real world improvements.

    #32588
    mikinho

    If you need it here is a KB article on enabling VMDq support: http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1026094

    Again, only enable if your Intel NIC supports it.

    #32590
    FantaXP7

    I’ve just ordered this card, before seeing these posts…http://www.newegg.com/Product/Product.aspx?Item=N82E16833106011

    It doesn’t seem to mention VMDq. Should I look at purchasing one that does?

    The reason for this second Intel NIC is I would like to keep one dedicated for my FreeNAS install.

    Thanks

    #32593
    mikinho

    That is a good card but if you want to maximize your IO when running as a virtual then http://www.newegg.com/Product/Product.aspx?Item=N82E16833106035&Tpk=E1G42ET is a better bet. It supports Virtual Machine Device Queues (VMDq) and SR-IOV

    #32594
    mikinho

    btw….Not saying you should or shouldn’t change the order. The PT is a great network card as well. It really comes down to your own expectations. I’m overly anal when it comes to network performance and stability.

    #32595
    FantaXP7

    [quote=mikinho]

    btw….Not saying you should or shouldn’t change the order. The PT is a great network card as well. It really comes down to your own expectations. I’m overly anal when it comes to network performance and stability.

    [/quote]

     

    I hear ya and I am sort of the same way, just don’t have much of the know-how with networking (gets quite confusing). 

    I will try out the one I first ordered and if things don’t clear up I will try out the second one. 

    Thanks again

    #32606
    FantaXP7

    So yesterday the Intel EXPI9400PTBLK came in and I saw some improvement with the tuner. I was able to watch live tv on two HTPC’s and switch channels without a problem. However I noticed two channels wouldn’t tune in, and previously they would. Also after awhile I saw a little bit of stuttering on a commercial…

    Anyways, the Intel E1G42ET will be coming in today and we’ll see what that does for me.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.